公式指标网,最大的股票公式,股票软件下载站 用户登录  |  用户注册
多周期MACD+支撑压力+画线(副图 源码 贴图)
  • 软件大小:5.00 KB
  • 推荐星级:
  • 更新时间:2012-01-25 04:10:25
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/
  • 相关Tags:画线  支撑压力  多周期MACD  
  • (0)0%
    (0)0%

软件简介

多周期MACD+支撑压力+画线(副图 源码 贴图)

这个指标集MACD的短中长周期、支撑压力、画线、支撑压力价以及其他辅助判断。大彩带为长周期MACD,小彩带为短周期MACD,线条为我们平时在用的MACD。短周期加入了顶背离和底背离的提示。另外有W底的提示及止跌的信号。这样就很好地克服了传统MACD的滞后性(你可以看短周期的),同时大周期可以让我们看清大趋势。源码如下:
参数N为1 100 3
DIFF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIFF1,9);
VARX2:=LLV(DEA1,43);
VARX3:=DEA1-(DIFF1-DEA1);
低点线:=IF(DIFF1<VARX2 AND DEA1=VARX2,MIN(HHV(VARX2,10),VARX3),VARX2);
VL:=REF(LOW,1);
VAR12:=(SMA(ABS(LOW-VL),13,1))/(SMA(MAX(LOW-VL,0),13,1))*100;
VAR14:=MA(VAR12,13);
VAR15:=LLV(LOW,34);
VAR18:=EMA(IF(LOW<=VAR15,VAR14,0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,8,1)*15-VAR110*10.38;
T:=FILTER(IF(VAR111<=VAR110 AND VAR18>0,VAR18*8,0),5);
止跌:DRAWTEXT(T AND DIFF1<低点线,DIFF1*1.01,'止跌'),COLORYELLOW;
{大周期}
DIF55:=(EMA(CLOSE,55)-EMA(CLOSE,119))*0.55;
DEA55:=(EMA(DIF55,41));
DRAWBAND(DEA55,RGB(0,100,50),DIF55,RGB(155,50,50));
{小周期}
DIF3_6.5F:=(EMA(CLOSE,3)-(EMA(CLOSE,6)+EMA(CLOSE,7))/2);
DEA3_6.5F:=(EMA(DIF3_6.5F,3)+EMA(DIF3_6.5,2));
DRAWBAND(DEA3_6.5F,RGB(100,100,300),DIF3_6.5F,RGB(100,300,150));
AA:=REF(DIF3_6.5F,N)=HHV(DIF3_6.5F,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND DIF3_6.5F=HHV(DIF3_6.5F,N+1);
A1:=BARSLAST(REF(CC,1));
顶背离:=REF(CLOSE,A1+1)<CLOSE AND REF(DIF3_6.5F,A1+1)>DIF3_6.5F AND CC;
DRAWTEXT(顶背离,DIF3_6.5F*1.2,'顶背离'),COLORGREEN;
DRAWLINE(CC,DIF3_6.5F,FILTER(顶背离>0,5),DIF3_6.5F,0),COLORWHITE,POINTDOT;
AA2:=REF(DIF3_6.5F,N)=LLV(DIF3_6.5F,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND DIF3_6.5F=LLV(DIF3_6.5F,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(CLOSE,A2+1)>CLOSE AND REF(DIF3_6.5F,A2+1)<DIF3_6.5F AND CC2;
DRAWTEXT(底背离,DIF3_6.5F*1.2,'底背离'),COLORMAGENTA;
DRAWLINE(CC2,DIF3_6.5F,FILTER(底背离>0,5),DIF3_6.5F,0),COLORWHITE,POINTDOT;
{中周期}
DIFF: EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE,LINETHICK2;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK2;
MACD: 2*(DIFF-DEA),COLORSTICK;
{形态}
A:=IF(CROSS(0,DEA),1,0);
A11:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A11,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A11,0);
W底:=SSS-SSB=2 AND SSS>REF(SSS,1);
DRAWTEXT(W底,DIFF,'↖W底'),COLORYELLOW;
{画趋势线}
M:=INTPART(3*10/5);
A12:=REF(DIFF,M)=HHV(DIFF,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
短压:DRAWLINE(D12,DIFF,S112,DIFF,1),COLORFF9966;
M1:=INTPART(3*20/5);
A111:=REF(DIFF,M1)=HHV(DIFF,2*M1+1);
B111:=FILTER(A111,M1);
C111:=BACKSET(B111,M1+1);
D1:=FILTER(C111,M1);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
长压:DRAWLINE(D1,DIFF,S11,DIFF,1),COLORFF99FF;
{支撑压力}
绿线天:=BARSLAST(CROSS(DEA,DIFF));
红线天:=BARSLAST(CROSS(DIFF,DEA));
压力:REF(H,绿线天),NODRAW;
支撑:REF(O,红线天),NODRAW;
{压力支撑价}
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW;
今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW;
明压:阻价,LINETHICK0,NODRAW;
明撑:支价,LINETHICK0,NODRAW;
 

下载地址(点击上图是广告,点击下图进入下载地址网页)

    多周期MACD+支撑压力+画线(副图 源码 贴图)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:理想论坛,老钱庄,创幻,MACD等论坛,谢谢各位老师的原创软件。为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.61才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc格式股票公式,可以用通达信股票软件引入使用;
* tni格式股票公式,仅可以用通达信新版本引入使用例如通达信v6.05以上版本,通达 信老版本不能引入;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费破解FNC大智慧公式;破 解hxf同花顺,daf操盘手,alg飞狐等原码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本网就可以有资 料说明编写过程,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含破解及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

特别声明:本站内所有广告其网站的一切言行均与本站无关,请广大投资者小心谨慎。
Copyright © 2003-2008 uu361.Cn. All Rights Reserved .
页面执行时间:594.72660 毫秒
网站备案信息:琼ICP备11002154号